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ABSTRACT  

Bookmarking Case Report Forms (CRFs) for regulatory submissions is a critical yet often labor-intensive 
task for statistical programmers. Manual bookmarking in Adobe Acrobat Pro™ is time-consuming, 
repetitive, and prone to human error, especially for large, multi-level documents. This paper presents a 
clear, step-by-step workflow for automating CRF bookmarking using the TRS toolbox™ (formerly ISI 
toolbox) plug-in for Adobe Acrobat Pro. By leveraging the toolbox’s import/export functionality and Excel 
templates, programmers can efficiently generate, edit, and apply complex bookmark structures with 
minimal manual intervention. This approach accelerates the submission preparation while improving 
accuracy, reproducibility, and compliance with regulatory requirements. The workflow is illustrated with 
practical procedures, template examples, and guidance for integrating screenshots, making it accessible 
for programmers seeking to streamline their CRF bookmarking. 

INTRODUCTION  

Statistical programmers play a pivotal role in preparing regulatory submission documents, including the 
creation of navigable, well-structured bookmarks in CRFs. Regulatory agencies such as the FDA and 
EMA require electronic submissions to be easily navigate, with bookmarks that reflect the document’s 
logical structure. Traditionally, programmers have relied on manual bookmarking in Adobe Acrobat Pro—
a process that is not only tedious but also susceptible to inconsistencies and errors, particularly when 
dealing with large or complex CRFs. 

The TRS toolbox, a robust plug-in for Adobe Acrobat Pro, offers a suite of tools designed to automate and 
standardize PDF management tasks. Of particular interest is its ability to export and import bookmark 
structures via Excel templates, enabling batch creation and editing of bookmarks. This paper details a 
practical workflow for automating CRF bookmarking, tailored to the needs of statistical programmers, and 
demonstrates how this approach can transform a labor-intensive process into a streamlined, reproducible 
task. 

OVERVIEW OF THE TRS TOOLBOX 

The TRS toolbox (formerly ISI toolbox) is a comprehensive plug-in for Adobe Acrobat Pro, developed to 
automate repetitive PDF tasks commonly encountered during regulatory submission preparation. As a 
prerequisite, users must have Adobe Acrobat Pro installed, as the TRS toolbox operates as an integrated 
plug-in within the Acrobat environment. The availability and installation of the TRS toolbox may vary by 
organization and is typically managed through an internal software distribution portal or coordinated 
through the company’s information technology (IT) team. 

Key features relevant to CRF bookmarking include: 

• Export/Import Tool: Export bookmarks and hyperlinks to Excel or CSV, edit them, and re-
import to apply changes. 

• Batch Processing: Apply bookmark templates across multiple documents. 

• Bookmark Editor and Auditor: Edit, QC, and validate bookmarks efficiently. 

Among these features, the Export/Import functionality is particularly valuable because it enables 
bookmark creation to be driven by a structured, reviewable Excel template rather than manual interaction 
within the PDF. 
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WORKFLOW OVERVIEW 

This section outlines the end‑to‑end workflow used to automate CRF bookmarking using the TRS toolbox 
and Excel templates. The approach focuses on exporting a correctly structured bookmark template, 
populating only the key fields required to define Visit‑level and Domain‑level bookmarks, and importing 
the completed template back into the CRF PDF. A final quality control step ensures that the generated 
bookmarks are accurate, navigable, and submission‑ready. 

Although this paper uses the eCRF as the primary example, the same Excel-driven bookmarking and 
validation approach can be applied to other regulatory submission documents. This includes, but is not 
limited to, clinical study reports (CSRs), protocols, statistical analysis plans (SAPs), and appendices, 
where structured bookmark hierarchies and navigation validation are similarly required. 

EXPORTING AN EMPTY BOOKMARK TEMPLATE 

The purpose of this step is to guide the user on how to obtain the Excel template required for CRF 
bookmarking using the TRS toolbox. This template will later be used to define the final bookmark 
structure that is applied to the CRF for regulatory submission. 

In theory, a blank Excel file with the required columns could be created manually. However, this approach 
is error prone and inefficient, as the column names, formats, and expected structure must exactly match 
what the TRS toolbox requires during import. A more reliable and efficient approach is to export a 
bookmark template directly from the PDF using the Export & Import function. This ensures the Excel file is 
correctly structured and immediately ready for use. 

In many cases, the raw annotated CRF exported from the EDC system already contains basic 
bookmarks, such as form names or page numbers. These existing bookmarks can be reused as a 
starting point. Exporting them into Excel allows the user to build upon the existing structure and complete 
the CRF bookmarking required for submission, rather than starting from scratch. 

STEP BY STEP INSTRUCTIONS 

1. Open the CRF PDF in Adobe Acrobat Pro. 

Note: If the CRF does not contain any bookmarks, at least one temporary bookmark must be 

created before exporting. The export process requires an existing bookmark to generate the 

Excel template. A simple test bookmark (for example, pointing to the first page of the 

document) is sufficient and can be removed later. 
 

2. Open the TRS Toolbox and navigate to: 

Menu→Plugins→Toolbox → Bookmark & Hyperlink Tools→ Export & Import. (See Display 1. TRS 
Toolbox Export & Import Menu Path in Adobe Acrobat Pro). 
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Display 1. TRS Toolbox Export & Import Menu Path in Adobe Acrobat Pro 

         

3. In the Export & Import dialog box, select Export. 

4. Check Bookmarks only. 

Do not select Links for this step. (see Display 2. TRS Toolbox Export/Import Dialog with 
Bookmarks Selected (Export Mode)) 

 

Display 2. TRS Toolbox Export/Import Dialog with Bookmarks Selected (Export Mode) 
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5. Select Excel (.xls) as the output format. 

6. Click Browse and choose a location to save the file. 

Use a clear file name, for example: CRF_Bookmark_Template.xls. 

7. Set Page Options to All. 

8. Click Start to export the bookmarks. (See Display 3. Export Bookmarks to Excel Using the 
Start Button) 

 

Display 3. Export Bookmarks to Excel Using the Start Button 

 

 
9. Open the exported Excel file and verify that it contains the bookmark related columns (for 

example, bookmark title, hierarchy level, destination page or named destination, and display 
attributes). 

At this point, the Excel file serves as the bookmark template. The file may be mostly empty, or it may 
already contain form level or page level bookmarks exported from the raw annotated CRF. In the next 
step, this template will be completed and refined to meet the CRF bookmarking requirements for 
regulatory submission. 

POPULATING THE EXCEL TEMPLATE 
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The exported Excel template contains multiple columns required by the TRS toolbox. For CRF 
bookmarking, most columns either use a constant value across all rows or are intentionally left blank. 
Only a small subset of columns must be populated by the user to define the Visit-level and Domain-level 
bookmark structure. 

Table 1. Instructions for Populating the Excel Bookmark Template provides clear guidance on how each 
column should be populated when creating CRF bookmarks. The table below focuses on practical usage 
rather than documenting every available column, highlighting only what must be populated, what should 
be carried across rows, and what can remain blank. 

Table 1. Instructions for Populating the Excel Bookmark Template 

Column Name Description How to Populate for CRF Bookmarking 

FILE_NAME 
File name and path of the 
CRF PDF. 

Enter the CRF PDF path (for example, 
C:\Users\...\ph3.pdf) and carry this value to all 
rows. 

TYPE 
Indicates whether the row 
is a bookmark or link. 

Enter “BOOKMARK” and carry this value to all 
rows. 

INDENT_SRCPAGE Bookmark hierarchy level. 

Populate. Use this column to define hierarchy: 
• Visit-level bookmarks: parent levels (for example, 
1, 1.02, 1.03). 
• Domain-level bookmarks: nested under the visit 
(for example, 1.02.01, 1.02.02). 

TITLE/TEXT Visible bookmark name. 

Populate. Enter bookmark names based on CRF 
structure: 
• Visit-level: Visit name (for example, PH3W4, 
PH3W12). 
• Domain-level: Form or domain name (for 
example, Laboratory Tests, Demographics). 

ACTION Bookmark action type. 
Enter “Goto_View_Internal” and carry this value to 
all rows. 

MAGNIFICATION 
Zoom behavior for 
destination page. 

Enter “INHERIT_ZOOM” and carry this value to all 
rows. 

DEST_PAGE 
Destination page number in 
the PDF. 

Populate. Enter the page number the bookmark 
should navigate to. Page numbers from the 
annotated CRF can be reused and updated as 
needed. 

DEST_FILE Destination file reference. 
Leave blank for CRF bookmarks within the same 
PDF. 

FULL_PATH 
Absolute destination file 
path. 

Leave blank.  

ZOOM Fixed zoom percentage. Enter ‘0’ and carry this value to all rows. 

DEST_RECT_L 
Destination rectangle left 
coordinate. 

Enter ‘0’ and carry this value to all rows. 

DEST_RECT_R 
Destination rectangle right 
coordinate. 

Enter ‘0’ and carry this value to all rows. 
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Column Name Description How to Populate for CRF Bookmarking 

DEST_RECT_B 
Destination rectangle 
bottom coordinate. 

Enter ‘0’ and carry this value to all rows. 

DEST_RECT_T 
Destination rectangle top 
coordinate. 

Enter ‘792’ and carry this value to all rows. 

LEFT 
Source rectangle left 
coordinate. 

Enter ‘NA’ and carry this value to all rows. 

RIGHT 
Source rectangle right 
coordinate. 

Enter ‘NA’ and carry this value to all rows. 

TOP 
Source rectangle top 
coordinate. 

Enter ‘NA’ and carry this value to all rows. 

BOTTOM 
Source rectangle bottom 
coordinate. 

Enter ‘NA’ and carry this value to all rows. 

COLOR Bookmark display color. Enter ‘RGB(0,0,0)’ and carry this value to all rows. 

STYLE_WIDTH Bookmark text style. Enter ‘Plain’ and carry this value to all rows. 

OPEN_IN_WINDOW 
Destination window 
behavior. 

Enter ‘Window set by user preference’ and carry 
this value to all rows. 

OPEN_CLOSE 
Bookmark expanded or 
collapsed state. 

Enter OPEN for Visit-level bookmarks and N/A for 
Domain-level bookmarks. 

NAMED_DEST 
Named destination 
reference. 

Leave blank  

ABSOLUTE_PATH 
Absolute vs relative path 
indicator. 

Enter ‘0’ 

HIGHLIGHT_STYLE Link highlight behavior. Leave blank.  

LINE_STYLE Link line style. Leave blank.  

 

COLUMNS THAT DRIVE CRF BOOKMARK CREATION 

When creating CRF bookmarks by Visit and Domain, the user primarily works with the following columns: 

• INDENT_SRCPAGE – defines Visit and Domain level hierarchy 

• TITLE/TEXT – defines the bookmark names displayed in the PDF 

• DEST_PAGE – defines where each bookmark navigates in the CRF 

All other columns either use constant values carried across the template or are intentionally left blank. 

An example of a populated Excel bookmark template is shown below (Display 4. Example of a Populated 
Excel Bookmark Template Highlighting Key User-Input Columns). In this example, the key columns 
requiring user input are highlighted within the green rectangle to clearly illustrate which fields must be 
populated to define the CRF bookmark structure. 
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Display 4. Example of a Populated Excel Bookmark Template Highlighting Key User-Input 
Columns 

 

In addition to manual editing, the Excel bookmark template can also be prepared programmatically. 
Because the template follows a structured, tabular format, it can be generated or populated using 
standard scripting or programming approaches (for example, from metadata, specifications, or controlled 
lists). This allows bookmark structures to be created, updated, or reused in a consistent and reproducible 
manner, particularly for large documents or repeated submissions. Once generated, the populated 
template can be imported into the PDF using the same TRS toolbox workflow described above. 

IMPORTING THE POPULATED TEMPLATE 

Once the Excel template has been populated with the required Visit level and Domain level bookmarks, 
the next step is to import the template back into the CRF PDF to generate the bookmarks automatically. 

Before importing, it is recommended to remove any existing bookmarks in the PDF to avoid duplication or 
conflicts. This ensures that the final bookmark structure is driven entirely by the Excel template. 

STEP BY STEP INSTRUCTIONS 

1. Open the CRF PDF in Adobe Acrobat Pro. 

2. If bookmarks already exist in the document, use the TRS toolbox to delete them: 

• Navigate to Menu → Plugins → Toolbox → Bookmark & Hyperlink Tools → Delete 
Bookmarks 

• Confirm deletion 

3. Open the TRS Toolbox and navigate to: 

Menu → Plugins → Toolbox → Bookmark & Hyperlink Tools → Export & Import. (see Display 
1. TRS Toolbox Export & Import Menu Path in Adobe Acrobat Pro) 

4. Select Import. 

Choose Excel (.xls) as the input format and browse to the populated Excel bookmark 
template. 

5. Confirm that Bookmarks is selected for import. 

6. Click Start to import the bookmarks. (see Display 5. Import Bookmarks from Excel Using the 
Export/Import Dialog (Import Mode)) 
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Display 5. Import Bookmarks from Excel Using the Export/Import Dialog (Import Mode) 

 

 
7. Once the import is complete, review the bookmark pane in the PDF to confirm that the Visit 

level and Domain level bookmarks have been created as expected. 

At the end of this step, the CRF PDF contains a fully populated bookmark structure generated directly 
from the Excel template. 

QUALITY CONTROL AND FINALIZATION 

After importing the bookmarks, a quality control (QC) step is performed to ensure that all bookmarks 
function correctly and meet submission requirements. QC focuses on both structural accuracy and 
navigation behavior. 

The TRS toolbox provides built in tools that allow bookmarks to be reviewed efficiently without manually 
clicking through each one. 

STEP BY STEP INSTRUCTIONS 

1. Open the Menu → Plugins → Toolbox →Bookmark & Link Auditor from the TRS Toolbox. (see 
Display 6. Launching Bookmark & Link Auditor from TRS Toolbox) 
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Display 6. Launching Bookmark & Link Auditor from TRS Toolbox 

 

 

2. Click on the “Scan” to load all “Bookmarks” into the Auditor Window. (see Display 7. Bookmark & 
Link Auditor: Scan to Load Bookmarks) 

Display 7. Bookmark & Link Auditor: Scan to Load Bookmarks 
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3. Next, run Audit. Bookmarks with missing destinations, invalid page references, or structural 
hierarchy issues will fail validation and appear in the audit results for correction. (See Display 8. 
Bookmark & Link Auditor: Audit Results and Validation Status) 

Display 8. Bookmark & Link Auditor: Audit Results and Validation Status 

 

 

4. Review and resolve any issues identified by the audit. 

5. Manually spot check bookmarks that point to critical CRF sections, such as: 

• Informed consent 

• Key efficacy assessments 

• Safety related forms 

6. Save the final CRF PDF once QC is complete. 

After QC, the CRF is ready for inclusion in the regulatory submission. Because the bookmark structure is 
defined in Excel, the same template can be reused or easily updated if page numbers or CRF content 
change. 

RESULTS 

Implementing this workflow, statistical programmers can: 

• Reduce manual effort: Bookmarking time for large CRFs drops from hours to minutes. 

• Increase accuracy: Excel-based editing minimizes human error and supports batch updates. 

• Enhance reproducibility: Templates can be reused across similar documents or studies. 

• Support compliance: The workflow aligns with regulatory requirements for bookmark structure, 
naming, and navigation. 
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DISCUSSION 

For statistical programmers, automating CRF bookmarking is a game-changer. The manual process is not 
only tedious but also diverts valuable time from higher-level programming and QC tasks. By adopting the 
TRS toolbox workflow: 

• Laborious tasks become streamlined. 

• Standardization ensures consistency across submissions. 

• Scalability supports single documents and large batches alike. 

• Transparency provides a clear, auditable record of bookmark structures. 

CONCLUSION  

Automating CRF bookmarking using the TRS toolbox’s import/export functionality and Excel templates 
offers significant efficiency and quality gains for statistical programmers. This workflow is scalable, 
reproducible, and supports compliance with regulatory requirements. Adoption of this approach can 
streamline submission preparation, reduce errors, and free programmers to focus on higher-value tasks. 
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